import re
regex = re.compile(r"(?<=CURRENT)(.|\n)*(?=\*Attention: Product Manager)", flags=re.MULTILINE)
test_str = ("*Before and after:\n\n"
"CURRENT\n\n"
"-----------------------------------------------------------------------------\n"
"Product ID : J73820\n"
"Quantity : 75\n"
"Title : Jeans\n"
"Brand: XXXX\n"
"-----------------------------------------------------------------------------\n"
"NEXT ACTION\n"
"Increase stock\n\n"
"TO BE\n\n"
"-----------------------------------------------------------------------------\n"
"Product ID : J73820\n"
"Quantity : 100\n"
"Title : Jeans\n"
"Brand: XXXX\n"
"-----------------------------------------------------------------------------\n"
"NEXT ACTION\n"
"Add 25 unit\n\n"
"*Attention: Product Manager\n"
"*Classification: N/A\n\n"
"C) For urgent product")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")