#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(define-fun\s+(\S+).*\n\s*(\d+)\)"
Local $sString = " (define-fun X_1 () Int" & @CRLF & _
" 281)" & @CRLF & _
" (define-fun X_71 () Int" & @CRLF & _
" 104)" & @CRLF & _
" (define-fun X_90 () Int" & @CRLF & _
" 21)" & @CRLF & _
" (define-fun X_54 () Int" & @CRLF & _
" 250)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")