re = /\(define-fun\s+(\S+).*\n\s*(\d+)\)/m
str = ' (define-fun X_1 () Int
281)
(define-fun X_71 () Int
104)
(define-fun X_90 () Int
21)
(define-fun X_54 () Int
250)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end