import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(define-fun\\s+(\\S+).*\\n\\s*(\\d+)\\)";
final String string = " (define-fun X_1 () Int\n"
+ " 281)\n"
+ " (define-fun X_71 () Int\n"
+ " 104)\n"
+ " (define-fun X_90 () Int\n"
+ " 21)\n"
+ " (define-fun X_54 () Int\n"
+ " 250)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}