package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(define-fun\s+(\S+).*\n\s*(\d+)\)`)
var str = ` (define-fun X_1 () Int
281)
(define-fun X_71 () Int
104)
(define-fun X_90 () Int
21)
(define-fun X_54 () Int
250)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}