using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http(s)?:\/\/|(w){3}).*\.((?:mp4)|).*(youtu(be|.be))?(\.com)?\/?.+";
string input = @" https://www.example.com/files/video.mp4
http://www.example.com/files/video.mp4
https://example.com/files/video.mp4
http://example.com/files/video.mp4
www.example.com/files/video.mp4
https://www.youtube.com/watch?v=xxxxxx
http://www.youtube.com/watch?v=xxxxxx
https://youtube.com/watch?v=xxxxxx
http://youtube.com/watch?v=xxxxxx
www.youtube.com/watch?v=xxxxxx
https://www.example.com/files/audio.mp3
http://www.youtu.be
www.sweaverd.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}