$re = '/(http(s)?:\/\/|(w){3}).*\.((?:mp4)|).*(youtu(be|.be))?(\.com)?\/?.+/m';
$str = ' https://www.example.com/files/video.mp4
http://www.example.com/files/video.mp4
https://example.com/files/video.mp4
http://example.com/files/video.mp4
www.example.com/files/video.mp4
https://www.youtube.com/watch?v=xxxxxx
http://www.youtube.com/watch?v=xxxxxx
https://youtube.com/watch?v=xxxxxx
http://youtube.com/watch?v=xxxxxx
www.youtube.com/watch?v=xxxxxx
https://www.example.com/files/audio.mp3
http://www.youtu.be
www.sweaverd.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);