import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http(s)?:\\/\\/|(w){3}).*\\.((?:mp4)|).*(youtu(be|.be))?(\\.com)?\\/?.+";
final String string = " https://www.example.com/files/video.mp4\n"
+ " http://www.example.com/files/video.mp4\n"
+ " https://example.com/files/video.mp4\n"
+ " http://example.com/files/video.mp4\n"
+ " www.example.com/files/video.mp4\n\n"
+ " https://www.youtube.com/watch?v=xxxxxx\n"
+ " http://www.youtube.com/watch?v=xxxxxx\n"
+ " https://youtube.com/watch?v=xxxxxx\n"
+ " http://youtube.com/watch?v=xxxxxx\n"
+ " www.youtube.com/watch?v=xxxxxx\n\n"
+ " https://www.example.com/files/audio.mp3\n"
+ " http://www.youtu.be\n"
+ "www.sweaverd.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}