// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http(s)?:\/\/|(w){3}).*\.((?:mp4)|).*(youtu(be|.be))?(\.com)?\/?.+").unwrap();
let string = " https://www.example.com/files/video.mp4
http://www.example.com/files/video.mp4
https://example.com/files/video.mp4
http://example.com/files/video.mp4
www.example.com/files/video.mp4
https://www.youtube.com/watch?v=xxxxxx
http://www.youtube.com/watch?v=xxxxxx
https://youtube.com/watch?v=xxxxxx
http://youtube.com/watch?v=xxxxxx
www.youtube.com/watch?v=xxxxxx
https://www.example.com/files/audio.mp3
http://www.youtu.be
www.sweaverd.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}