# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\w"])"+(?=\S)/$1?/gm;t' <<< "abc-1\"-def321
\"abc-1\"-def321\"
\"aloha\""