const regex = /([\w"])"+(?=\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w"])"+(?=\\S)', 'gm')
const str = `abc-1"-def321
"abc-1"-def321"
"aloha"`;
const subst = `$1?`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);