#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([\w"])"+(?=\S)"
Local $sString = "abc-1"-def321" & @CRLF & _
"" & @CRLF & _
""abc-1"-def321"" & @CRLF & _
"" & @CRLF & _
""aloha""
Local $sSubst = "$1?"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)