use strict;
my $str = 'abc-1"-def321
"abc-1"-def321"
"aloha"';
my $regex = qr/([\w"])"+(?=\S)/mp;
my $subst = '$1?';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";