re = /([\w"])"+(?=\S)/m
str = 'abc-1"-def321
"abc-1"-def321"
"aloha"'
subst = '$1?'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result