const regex = new RegExp('^\\s*
(?:
(\\w+)\\s*\\(\\s*\\)\\s*
|
function\\s+(\\w+)\\s*
)
(
[^{}*]*
(
\\{[^{}]*\\}
[^{}]*
)*
)', 'mgs')
const str = `function nvim() {
file="\$1"
if [[ -n \${file-} ]]; then
command nvim "\$file" && echo -ne '\\\\e[0 q'
else
command nvim && echo -ne '\\\\e[0 q'
fi
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}