import re
regex = re.compile(r"""
^\s*
(?:
(\w+)\s*\(\s*\)\s*
|
function\s+(\w+)\s*
)
(
[^{}*]*
(
\{[^{}]*\}
[^{}]*
)*
)
""", flags=re.MULTILINE | re.VERBOSE | re.DOTALL)
test_str = ("function nvim() {\n"
" file=\"$1\"\n"
" if [[ -n ${file-} ]]; then\n"
" command nvim \"$file\" && echo -ne '\\\\e[0 q'\n"
" else\n"
" command nvim && echo -ne '\\\\e[0 q'\n"
" fi\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")