$re = '/^\s*
(?:
(\w+)\s*\(\s*\)\s*
|
function\s+(\w+)\s*
)
(
[^{}*]*
(
\{[^{}]*\}
[^{}]*
)*
)/mxs';
$str = 'function nvim() {
file="$1"
if [[ -n ${file-} ]]; then
command nvim "$file" && echo -ne \'\\\\e[0 q\'
else
command nvim && echo -ne \'\\\\e[0 q\'
fi
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);