re = /^\s*
(?:
(\w+)\s*\(\s*\)\s*
|
function\s+(\w+)\s*
)
(
[^{}*]*
(
\{[^{}]*\}
[^{}]*
)*
)/mx
str = 'function nvim() {
file="$1"
if [[ -n ${file-} ]]; then
command nvim "$file" && echo -ne \'\\\\e[0 q\'
else
command nvim && echo -ne \'\\\\e[0 q\'
fi
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end