// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mxs)^\s*
(?:
(\w+)\s*\(\s*\)\s*
|
function\s+(\w+)\s*
)
(
[^{}*]*
(
\{[^{}]*\}
[^{}]*
)*
)").unwrap();
let string = "function nvim() {
file=\"$1\"
if [[ -n ${file-} ]]; then
command nvim \"$file\" && echo -ne '\\\\e[0 q'
else
command nvim && echo -ne '\\\\e[0 q'
fi
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}