#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)|^((?:/[^/\n]*){3}/))([^\d\n]*)\d"
Local $sString = "/path/to/something/1234/end" & @CRLF & _
"/path/to/something/12/1234/end" & @CRLF & _
"" & @CRLF & _
"/FWS/teis-facade-rest_v712/flk/tariffs/114776/14/options" & @CRLF & _
"/mem-utms-facade/v1.2/rest/URA/ST00006486/note" & @CRLF & _
"/FWS/spg-facade/eis/2650114465322000006/contract" & @CRLF & _
"/FWS/fanotical-soyarty-service/flk/lk_2456882/bonusFlk"
Local $sSubst = "$1$2#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)