using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|^((?:/[^/\n]*){3}/))([^\d\n]*)\d";
string substitution = @"$1$2#";
string input = @"/path/to/something/1234/end
/path/to/something/12/1234/end
/FWS/teis-facade-rest_v712/flk/tariffs/114776/14/options
/mem-utms-facade/v1.2/rest/URA/ST00006486/note
/FWS/spg-facade/eis/2650114465322000006/contract
/FWS/fanotical-soyarty-service/flk/lk_2456882/bonusFlk";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}