import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!^)|^((?:/[^/\\n]*){3}/))([^\\d\\n]*)\\d";
final String string = "/path/to/something/1234/end\n"
+ "/path/to/something/12/1234/end\n\n"
+ "/FWS/teis-facade-rest_v712/flk/tariffs/114776/14/options\n"
+ "/mem-utms-facade/v1.2/rest/URA/ST00006486/note\n"
+ "/FWS/spg-facade/eis/2650114465322000006/contract\n"
+ "/FWS/fanotical-soyarty-service/flk/lk_2456882/bonusFlk";
final String subst = "$1$2#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}