import re
regex = re.compile(r"(?:\G(?!^)|^((?:/[^/\n]*){3}/))([^\d\n]*)\d", flags=re.MULTILINE)
test_str = ("/path/to/something/1234/end\n"
"/path/to/something/12/1234/end\n\n"
"/FWS/teis-facade-rest_v712/flk/tariffs/114776/14/options\n"
"/mem-utms-facade/v1.2/rest/URA/ST00006486/note\n"
"/FWS/spg-facade/eis/2650114465322000006/contract\n"
"/FWS/fanotical-soyarty-service/flk/lk_2456882/bonusFlk")
subst = "$1$2#"
result = regex.sub(subst, test_str)
if result:
print(result)