#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=father.*?)mother|mother(?=.*?father)|(?<=mother.*?)father|father(?=.*?mother)"
Local $sString = "Postive matches:" & @CRLF & _
"mother a father" & @CRLF & _
"father a mother" & @CRLF & _
"father a mother a father" & @CRLF & _
"mother a father a mother" & @CRLF & _
"" & @CRLF & _
"Non-matches:" & @CRLF & _
"just mother" & @CRLF & _
"just father" & @CRLF & _
"mother then mother" & @CRLF & _
"father then father" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")