const regex = /(?<=father.*?)mother|mother(?=.*?father)|(?<=mother.*?)father|father(?=.*?mother)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=father.*?)mother|mother(?=.*?father)|(?<=mother.*?)father|father(?=.*?mother)', 'gm')
const str = `Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
Non-matches:
just mother
just father
mother then mother
father then father
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}