import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=father.*?)mother|mother(?=.*?father)|(?<=mother.*?)father|father(?=.*?mother)";
final String string = "Postive matches:\n"
+ "mother a father\n"
+ "father a mother\n"
+ "father a mother a father\n"
+ "mother a father a mother\n\n"
+ "Non-matches:\n"
+ "just mother\n"
+ "just father\n"
+ "mother then mother\n"
+ "father then father\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}