$re = '/(?<=father.*?)mother|mother(?=.*?father)|(?<=mother.*?)father|father(?=.*?mother)/m';
$str = 'Postive matches:
mother a father
father a mother
father a mother a father
mother a father a mother
Non-matches:
just mother
just father
mother then mother
father then father
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);