package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https:\/\/sports\.hummerball\.com\/betting\/[\w-]+\/football\/OB_EV(\d+)\/`)
var str = `https://sports.hummerball.com/betting/en-gb/football/OB_EV21090572/decic-vs-drita`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}