import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https:\\/\\/sports\\.hummerball\\.com\\/betting\\/[\\w-]+\\/football\\/OB_EV(\\d+)\\/";
final String string = "https://sports.hummerball.com/betting/en-gb/football/OB_EV21090572/decic-vs-drita";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}