$re = '/^https:\/\/sports\.hummerball\.com\/betting\/[\w-]+\/football\/OB_EV(\d+)\//m';
$str = 'https://sports.hummerball.com/betting/en-gb/football/OB_EV21090572/decic-vs-drita';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);