const regex = /^https:\/\/sports\.hummerball\.com\/betting\/[\w-]+\/football\/OB_EV(\d+)\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/sports\\.hummerball\\.com\\\/betting\\\/[\\w-]+\\\/football\\\/OB_EV(\\d+)\\\/', 'gm')
const str = `https://sports.hummerball.com/betting/en-gb/football/OB_EV21090572/decic-vs-drita`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}