re = /^https:\/\/sports\.hummerball\.com\/betting\/[\w-]+\/football\/OB_EV(\d+)\//m
str = 'https://sports.hummerball.com/betting/en-gb/football/OB_EV21090572/decic-vs-drita'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end