# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S[^\S\n]*\n)[^\S\n]*\n(?![^\S\n]*\n)/$1/g;t' <<< "
<nav>
<ul>
<li><a href=\"#\">London</a></li>
<li><a href=\"#\">Paris</a></li>
<li><a href=\"#\">Tokyo</a></li>
</ul>
</nav>
<div>new context</div>
<div>new context</div>"