import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S[^\\S\\n]*\\n)[^\\S\\n]*\\n(?![^\\S\\n]*\\n)";
final String string = "\n\n"
+ "<nav>\n"
+ " \n"
+ " <ul>\n\n"
+ " <li><a href=\"#\">London</a></li>\n\n"
+ " <li><a href=\"#\">Paris</a></li>\n\n"
+ " <li><a href=\"#\">Tokyo</a></li>\n\n"
+ " </ul>\n\n"
+ "</nav>\n\n\n\n"
+ "<div>new context</div>\n\n\n\n"
+ "<div>new context</div>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}