import re
regex = re.compile(r"(\S[^\S\n]*\n)[^\S\n]*\n(?![^\S\n]*\n)")
test_str = ("\n\n"
"<nav>\n"
" \n"
" <ul>\n\n"
" <li><a href=\"#\">London</a></li>\n\n"
" <li><a href=\"#\">Paris</a></li>\n\n"
" <li><a href=\"#\">Tokyo</a></li>\n\n"
" </ul>\n\n"
"</nav>\n\n\n\n"
"<div>new context</div>\n\n\n\n"
"<div>new context</div>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)