const regex = /(\S[^\S\n]*\n)[^\S\n]*\n(?![^\S\n]*\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S[^\\S\\n]*\\n)[^\\S\\n]*\\n(?![^\\S\\n]*\\n)', 'g')
const str = `
<nav>
<ul>
<li><a href="#">London</a></li>
<li><a href="#">Paris</a></li>
<li><a href="#">Tokyo</a></li>
</ul>
</nav>
<div>new context</div>
<div>new context</div>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);