#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\+234\(\d{4}\)\d{3}-\d{4}"
Local $sString = "+234(999)999-9999" & @CRLF & _
"+235(9999)999-9999" & @CRLF & _
"+234(9999)9991-9999" & @CRLF & _
"+234(3456)333-333" & @CRLF & _
"+234(4444)333-4444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")