const regex = /\+234\(\d{4}\)\d{3}-\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+234\\(\\d{4}\\)\\d{3}-\\d{4}', 'gm')
const str = `+234(999)999-9999
+235(9999)999-9999
+234(9999)9991-9999
+234(3456)333-333
+234(4444)333-4444`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}