re = /\+234\(\d{4}\)\d{3}-\d{4}/m
str = '+234(999)999-9999
+235(9999)999-9999
+234(9999)9991-9999
+234(3456)333-333
+234(4444)333-4444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end