package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+234\(\d{4}\)\d{3}-\d{4}`)
var str = `+234(999)999-9999
+235(9999)999-9999
+234(9999)9991-9999
+234(3456)333-333
+234(4444)333-4444`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}