// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\+234\(\d{4}\)\d{3}-\d{4}").unwrap();
let string = "+234(999)999-9999
+235(9999)999-9999
+234(9999)9991-9999
+234(3456)333-333
+234(4444)333-4444";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}