using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<hi\s*rend=""\w*"">)([\w\s()]*[^<])(@{2,3}\d{1,2}?)([\w\s()]*[^<])?(<\/hi>)";
string input = @"This jus might be the result either of traditional and inveterate custom <hi rend=""italic"">(jus moribus constitutum</hi> or of statute <hi rend=""italic"">(lex).@@3As to the customs</hi>, it can well be believed that at the outset they were far from uniform; that not only the customs of the three original tribes.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}