import re
regex = re.compile(r"(<hi\s*rend=\"\w*\">)([\w\s()]*[^<])(@{2,3}\d{1,2}?)([\w\s()]*[^<])?(<\/hi>)")
test_str = "This jus might be the result either of traditional and inveterate custom <hi rend=\"italic\">(jus moribus constitutum</hi> or of statute <hi rend=\"italic\">(lex).@@3As to the customs</hi>, it can well be believed that at the outset they were far from uniform; that not only the customs of the three original tribes."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")