import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<hi\\s*rend=\"\\w*\">)([\\w\\s()]*[^<])(@{2,3}\\d{1,2}?)([\\w\\s()]*[^<])?(<\\/hi>)";
final String string = "This jus might be the result either of traditional and inveterate custom <hi rend=\"italic\">(jus moribus constitutum</hi> or of statute <hi rend=\"italic\">(lex).@@3As to the customs</hi>, it can well be believed that at the outset they were far from uniform; that not only the customs of the three original tribes.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}