import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/root\\/[^\\/\\n]+(?:\\/index\\.shtml)?$";
final String string = "/root/index.shtml\n"
+ "/root/root_one.shtml\n"
+ "/root/one/index.shtml\n"
+ "/root/two/index.shtml\n"
+ "/root/two/test.shtml\n"
+ "/root/two/three/index.shtml\n"
+ "/root/2024/index.shtml\n"
+ "/root/2024/one.shtml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}