import re
regex = re.compile(r"^\/root\/[^\/\n]+(?:\/index\.shtml)?$", flags=re.MULTILINE)
test_str = ("/root/index.shtml\n"
"/root/root_one.shtml\n"
"/root/one/index.shtml\n"
"/root/two/index.shtml\n"
"/root/two/test.shtml\n"
"/root/two/three/index.shtml\n"
"/root/2024/index.shtml\n"
"/root/2024/one.shtml")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")