#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((Monday|Tuesday|Wednesday|Thursday|Friday|Saturday|Sunday)(?!.*\2)(, |$))*$"
Local $sString = "Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday" & @CRLF & _
"Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Saturday" & @CRLF & _
"Monday, Tuesday, Wednesday, Thursday, Friday, Saturday" & @CRLF & _
"Monday, Monday" & @CRLF & _
"Monday"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")