$re = '/^((Monday|Tuesday|Wednesday|Thursday|Friday|Saturday|Sunday)(?!.*\2)(, |$))*$/m';
$str = 'Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday
Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Saturday
Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
Monday, Monday
Monday';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);