re = /^((Monday|Tuesday|Wednesday|Thursday|Friday|Saturday|Sunday)(?!.*\2)(, |$))*$/m
str = 'Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday
Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Saturday
Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
Monday, Monday
Monday'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end