use strict;
my $str = 'Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Sunday
Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, Saturday
Monday, Tuesday, Wednesday, Thursday, Friday, Saturday
Monday, Monday
Monday';
my $regex = qr/^((Monday|Tuesday|Wednesday|Thursday|Friday|Saturday|Sunday)(?!.*\2)(, |$))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}